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Database : A database is a repository of data. It is a tool for organizing, managing and retrieving
information. In Excel, the worksheet may be used as a database or list to easily store and manipulate
complex data. A database may be used to
•
•
•
•
•

Search or query to find specific data.
Sort data alphabetically and numerically by rows or columns in ascending or descending order.
Extract subsets of data based on certain criteria.
Perform statistical calculation on the data for analysis and decision making
Print data organized for specific purposes.

Parts of a database :
Field : Each column in a list is a separate field. A different field is used for each item that needs to be
accessed separately.
Field Name : A field name is a name that identifies the data stored in a field. The top row of a database
must contain the field name.
Record : A record is a single row in a database. Each record contains the same categories of data as
every other record in the database.
Computed Field : A field containing formulas or functions.
Database Range : A range is a rectangular group of worksheet cells defined as the list or database.

SORTING
Sorting data is an integral part of data analysis. You might want to put a list of names in alphabetical
order, compile a list of product inventory levels from highest to lowest, or order rows by colors or icons.
Sorting data helps you quickly visualize and understand your data better, organize and find the data that
you want, and ultimately make more effective decisions.
To perform a simple sort –

Click any cell in the database list in the column that you want to sort.

On the Home tab go to Edit group and click on Sort & Filter.

If the column contains numeric data then choose the option Sort Smallest to Largest or Largest
to Smallest whichever you want. Otherwise, if the column contains text data then choose the option
Sort A to Z or Z to A whichever you want.
Excel will sort the entire list according to the column you were in.
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To sort by multiple column –
Step 1 : Select the range of data you want to sort
Step 2 : Click on Data tab.
Step 3 : In Sort & Filter group, click on Sort to bring up the Sort dialog box.
Step 4 : Under the column heading in the dialog box, click on the down arrow to bring the drop down
list and select the filed you want to sort.
Step 5 : Under the Sort Order heading, click on the down arrow to bring the drop down list and select
the required option.
Step 6 : Click on the Add Level button at the top of the dialog box to add a second sort option.
Step 7 : Repeat step 4 and step 5.
Step 8 : Click OK in the dialog box to close the dialog box and sort the data.
Data Validation : Data validation is used to control the type of data or the values that users enter into a
cell. For example, one may want to restrict data entry so that only those data which fulfills a certain
criteria (for example, only positive integers) can be entered or one may limit choices by using a drop
down list, etc.
Creating drop down list for data validation :
 Select the cell where you want the drop-down list
 On the Data tab, in the Data Tools group, click Data Validation. The Data Validation dialog
box is displayed.
 Click the Settings tab.
 In the Allow box, click List.
 To specify the
 To specify the location of the list of valid entries, do one of the following:
•

If the list is in the current worksheet, enter a reference to your list in the Source box.

•

If the list is on a different worksheet, enter the name that you defined for your list in the
Source box.

•

In both cases, make sure that the reference or name is preceded with an equal sign (=).

 Make sure that the In-cell drop-down check box is selected.
 To specify whether the cell can be left blank, select or clear the Ignore blank check box.
 Optionally, we can display an input message when the cell is clicked.
 We can also specify how Microsoft Office Excel will to respond when invalid data is entered.
Note that the maximum number of entries that you can have in a drop-down list is 32,767.

3

Goal Seek

Goal Seek is an important facility provided by Excel to adjust the input value to get a predefined
result which contains a formula. If you know the result that you want from a formula, but not the
input value the formula needs to get that result, you can use the Goal Seek feature. To perform
Goal Seek, following steps are to be performed 1. On the Data tab, in the Data Tools group, click What-If Analysis, and then click Goal
Seek.
2. In the Set cell box, enter the reference for the cell that contains the formula (formula: A
sequence of values, cell references, names, functions, or operators in a cell that together
produce a new value. A formula always begins with an equal sign (=).) you want to resolve.
3. In the To value box, type the result you want.
4. In the By changing cell box, enter the reference for the cell that contains the value you
want to adjust.
NOTE
cell box.

This cell must be referenced by the formula in the cell you specified in the Set
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Filtering
Filtering data in a spreadsheet means to set conditions so that only certain data is displayed. It is done
to make it easier to focus on specific information in a large range of data. For example, if you have a list
of students and their total marks you can use filtering to show all the students who have scored marks
above a certain value, or ones who have scored marks under a certain value or ones who have scored
marks of an exact value. Filters works with rows of data. The conditions that are set are compared with
one or more fields in the record. If the conditions are met, the record is displayed. If the conditions are
not met, the record is filtered out so that it isn't displayed with the rest of the data records. Filtering
does not permanently remove records it just temporary hides them from view.
You can use an Auto-filter which can do quick filters based on what cells are already there and their
values. You can select various columns to be used as the filter and do things like already mentioned and
do things like show a set amount of values, like the top 10 values. There is also a feature called an
Advanced Filter which allows you to set up more complex criteria and do things like get the values that
result from the filter and put them into another part of the spreadsheet.

Auto Filter
An AutoFilter lets you limit the data displayed, but it’s limited as it depends on the actual data.
Step 1 :
Input all of your data, or open the spreadsheet that contains all of your data. It is best that your data
have column heading to specify the data below it. If you don’t already have these, input them before
you filter. Select all the data you wish to filter.
 Because the AutoFilter option is an automatic process that does not receive any specific
inputs on how to filter, it is recommended that you choose ‘’all’’ of the data you have. This
will avoid the possibility that you lose data associations across rows and/or columns.

Step 2 :
•

Click “Data” and then select “Filter”.
OR
• Under the Home Tab in the Editing group click on Sort and Filter and then click on Filter.

Step 3 :
•

You will notice that the headings now have drop-down buttons. Using these buttons, you can set
your filter options.

Sort Ascending : Sorts data in ascending order based on the data in that column; numbers are sorted 1,
2, 3, 4, 5, etc. and words are sorted alphabetically starting with a, b, c, d, e, etc.
Sort Descending : sorts data in descending order based on the data in that column; numbers are sorted
in reverse order 5, 4, 3, 2, 1, etc. and words are sorted in reverse alphabetical order, e, d, c, b, a, etc.
Top 10 : The first 10 rows of data in your spreadsheet (when initial setting is “All”) or the first 10 rows of
data from the filtered selection
Custom : You may customize how Excel sorts the data based on data ranges and information.
Various data points : You may sort the data based on all other data points in that column. Excel
combines data points that are the same. For example, employees that live in the same city can be sorted
using only one data point.

Step 4 :
•

To turn off AutoFilter, repeat step 2 to uncheck the AutoFilter option.
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Advanced Filter
The advanced filter feature in Excel can help the user extract useful information from a range of data
based on multiple criteria. You can use advanced filters to create more complicated conditions to filter a
table. Excel’s Advanced Filter feature requires a bit of setup, but is more flexible and powerful than an
AutoFilter. Not only can you use an expression to match records, you can combine expressions using the
And and Or operators
Excel’s Advanced Filter feature requires three elements:
•
•
•

Data
A criteria range, where you specify criteria as an expression.
An extract range, where Excel displays the data that satisfies the criteria.

Procedures
•
•
•
•

Drag to select the table Header Row.
Click the Copy button in the Clipboard group.
Select the cell where you want to create the criteria range.
Click the top part of the Paste button in the Clipboard group

Note : There must be at least one blank row between the criteria range and the table.
•
•
•
•
•
•

Select the cell below the criteria label corresponding to the table column you want to search.
Type the desired criteria.
Press [Enter]
Select any cell in the table.
Select the Data tab.
Select
in the Sort & Filter group.

•
•

Click the Collapse Dialog
button in the Criteria range box.
Drag to select the criteria range.

•
•
•
•
•

Click the Expand Dialog
button in the Advanced Filter - Criteria Range dialog box.
Under Action, select the Copy to another location option.
Click the Collapse Dialog button in the Copy to box.
Select the cell in the upper left corner of the location to which you want to copy the filtered
data.
Click the Expand Dialog button in the Advanced Filter - Copy To dialog box.

•

Select
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Scenarios
Scenarios are part of a suite of commands sometimes called what-if analysis tools. A scenario is a set of
values that Microsoft Office Excel saves and can substitute automatically on your worksheet. You can
use scenarios to forecast the outcome of a worksheet model. You can create and save different groups
of values on a worksheet and then switch to any of these new scenarios to view different results.

Creating Scenarios
1. On the Data tab, in the Data Tools group, click What-If Analysis, and then click Scenario
Manager.
2. Click Add.
3. In the Scenario name box, type a name for the scenario.
4. In the Changing cells box, enter the references for the cells that you want to change.
NOTE

To preserve the original values for the changing cells, create a scenario that uses the

original cell values before you create scenarios that change the values.
5. Under Protection, select the options that you want.
6. Click OK.
7. In the Scenario Values dialog box, type the values that you want for the changing cells.
8. To create the scenario, click OK.
9. If you want to create additional scenarios, repeat steps 2 through 8. When you finish creating
scenarios, click OK, and then click Close in the Scenario Manager dialog box.

Display a Scenario
1. On the Data tab, in the Data Tools group, click What-If Analysis, and then click Scenario
Manager.
2. Click the name of the scenario that you want to display.
3. Click Show.

Create a scenario summary report
1. On the Data tab, in the Data Tools group, click What-If Analysis, and then click Scenario
Manager.
2. Click Summary.
3. Click Scenario summary or Scenario PivotTable report.
4. In the Result cells box, enter the references for the cells that refer to cells whose values are
changed by the scenarios. Separate multiple references with commas.
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MACRO
If you perform a task repeatedly in Microsoft Excel, you can automate the task with a macro. A macro is
a series of commands and functions that are stored in a Microsoft Visual Basic module and can be run
whenever you need to perform the task. For example, if you often enter long text strings in cells, you
can create a macro to format those cells so that the text wraps.
Recording macros
When you record a macro, Excel stores information about each step you take as you perform a series of
commands. You then run the macro to repeat, or "play back," the commands. If you make a mistake
when you record the macro, corrections you make are also recorded. Visual Basic stores each macro in a
new module attached to a workbook.
Record a Macro
1. If the Developer tab is not available, do the following to display it:
• Click the Microsoft Office Button, and then click Excel Options.
• In the Popular category, under Top options for working with Excel, select the Show
Developer tab in the Ribbon check box, and then click OK.
2. On the Developer tab, in the Code group, click Record Macro.
3. In the Macro name box, enter a name for the macro.
4. To assign a CTRL combination shortcut key to run the macro, in the Shortcut key box, type any
lowercase letter or uppercase letter that you want to use.
5. In the Store macro in list, select the workbook in which you want to store the macro.
6. To include a description of the macro, in the Description box, type the text that you want.
7. Click OK to start recording.
8. Perform the actions that you want to record.
9. On the Developer tab, in the Code group, click Stop Recording
Run a Macro
1.
Open the workbook that contains the macro.
2.
On the Developer tab, in the Code group, click Macros.
3.
In the Macro name box, click the macro that you want to run.
4.
To run a macro in an Excel workbook, click Run.

